D24T.com  

Go Back   D24T.com > Technical Discussion Area > Help! My car died!

Reply
 
Thread Tools Display Modes
  #11  
Old 08-21-2023, 02:04 AM
BogfordGarage BogfordGarage is offline
Member
 
Join Date: Aug 2020
Location: Devon, UK
Vehicle: 1990 Volvo 940 TD & 1989 Volvo 760 TD
Posts: 59
Default

The pressure is a bit higher than you suggested but I hope this will do the job.
https://www.ebay.co.uk/itm/394655992...mis&media=COPY
Reply With Quote
  #12  
Old 08-22-2023, 09:33 AM
ngoma ngoma is offline
Supporting Member
 
Join Date: Nov 2009
Posts: 1,366
Default

Should be OK.
__________________
1985 744 gle d24t
1985 745 gle d24t
Reply With Quote
  #13  
Old 08-27-2023, 10:12 AM
BogfordGarage BogfordGarage is offline
Member
 
Join Date: Aug 2020
Location: Devon, UK
Vehicle: 1990 Volvo 940 TD & 1989 Volvo 760 TD
Posts: 59
Default

Okay, so after a lot of messing about I installed the inline pump and installed a new fuel line from the filter to the pump, then no start at all! Even though it ran with a temporary mock up before fully mounting the pump. Eventually we got it to start but it soon cut out after a short drive but at least it was now replicating the results. We eventually narrowed the issue to the 1 year old genuine Bosch stop solenoid. I replaced it with an old spare and removed power to inline fuel pump and so far so good. It also seems to have lost the air bubbles so I'm thinking that could have been one of the banjos on the filter housing. Many thanks to Ngoma and hopefully my experience will be useful to others in the future.
Reply With Quote
  #14  
Old 08-28-2023, 08:59 AM
ngoma ngoma is offline
Supporting Member
 
Join Date: Nov 2009
Posts: 1,366
Default

Good job!
__________________
1985 744 gle d24t
1985 745 gle d24t
Reply With Quote
  #15  
Old 09-22-2023, 06:16 PM
Intercooler-BurnzZ Intercooler-BurnzZ is offline
Junior Member
 
Join Date: May 2019
Location: Germany / Lower Saxony
Vehicle: '88 745 D24T ~370tkm; '94 945 D24TIC ~325tkm; '83 Honda 650 GL Silver Wing ~78tkm
Posts: 20
Default

Sounds like a pretty similar issue I had with my previous '95 945 D24TIC nine years ago. One month after reassembling the whole car it just stopped working at high speed on the motorway, the power was lost and taping the clutch the engine died immediately, in the darkness! Luckily I rolled it out on the side lane, after cranking it about 30 seconds it came back and I was able to drive it on to my girlfriends' place, without another issue, but I drove slower. I drove it a few days later in the city, but somehow it was kinda not running very stable, at higher throttle it decreased the idle rpm, almost dying.
... long story, at all. Later reason (years after I sold the car) one of the new owners in Sweden told me there was big muck in the tank, so it wasn't able at all to get the clean diesel through it and it was pretty jammed.
So the tank and filters needed to be cleaned, then everything was fine again.

Best regards, Bernd
__________________
...D24T(IC) is THE ULTIMATE engine sound in my ears!

Last edited by Intercooler-BurnzZ; 09-22-2023 at 06:19 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 05:15 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2024, vBulletin Solutions, Inc.