Go Back   D24T.com > Technical Discussion Area > Body and Interior

Thread Tools Display Modes
Old 02-12-2015, 12:15 AM
dustyv dustyv is offline
Junior Member
Join Date: Nov 2009
Location: Plymouth, Devon
Vehicle: 88 Volvo 745 TD, 2001 Peugeot 406 Tdi
Posts: 2
Default Flickering lights

My 1988 745 Turbo Diesel Estate has just developed an issue with the lights flickering.
Start the beast, after a short while, noticeably at idle, but occasionally does it under power.
Sometimes doesn't do it at all - but events of it happening are now becoming more frequent.
This is all lights, head, side, dashboard.
What could cause this?
The battery is new, the alternator was new (refurbished) about 5 years ago.
All connections have been checked (by me) and seem to be OK.
Could this be an earthing issue?
Alternator on it's way out?
Or something more sinister?
Obliged for all and any advice offered.
Reply With Quote
Old 02-12-2015, 12:42 AM
raw raw is offline
Join Date: May 2013
Location: Northamptonshire, England
Posts: 71

Just a guess but Earth connections would be my first point to check, they're the only things I've ever found that are able to cause symptoms as widespread as you describe.

Reply With Quote
Old 02-12-2015, 10:57 AM
745 TurboGreasel 745 TurboGreasel is offline
Senior Member
Join Date: Sep 2012
Location: Freedom CA
Vehicle: 85 745, 84Suburban 96Ram
Posts: 507

or the glow plugs are cycling?
Reply With Quote
Old 02-13-2015, 06:15 AM
v8volvo v8volvo is offline
Join Date: Jun 2009
Location: WA
Vehicle: '86 745, '83 764
Posts: 987

Ground connections/battery terminals seems like something worth checking for sure. On US market diesels (through 1986) the alternator mounts low on the right side of the motor, near the turbo, and one of its mounting points is direct to metal (no rubber bushing) so our diesels don't use a ground wire for the alt case; however, gasssers here (with rubber isolators on all alt mounting points) do need a wire. Don't know how your later Euro-market diesel is configured, but if it's an all-rubber mounting alt that uses a ground wire, you'll want to particularly check those connections.

What's your charging voltage? I had a 245 a few years back that developed a similar, intermittent issue... traced it to a faulty (aftermarket) brush pack/voltage regulator which was letting alternator output vary in a pulsing cycle, for reasons I don't understand. Alternator was an aftermarket refurb with an unknown-brand regulator in it... put a Bosch part in and all was well. You say yours was overhauled a few years ago -- it wouldn't be too soon for something on it to fail, especially if that part is sub-OE quality.

You'd be able to test for any of this with a voltmeter on the battery terminals while idling. Voltmeter across the two batt posts will show charging voltage and any fluctuation. Meter (set on VDC) across alternator case to battery negative terminal, or to car body, or from any other place you suspect possible/intermittent voltage drop (e.g. from battery negative terminal to post, car body to negative post or to alternator case, will show any drop present as a positive or negative reading... etc. If it's a ground integrity problem, you'll pinpoint it this way. Or if it's GP's cycling (somehow?) you can test for voltage at the GP buss when the symptom is present... Or if it's in the alternator, you'll find grounds all OK but fluctuating charge V whenever the problem is occurring.

As long as you can manage to get it to present the symptoms while testing, you should be able to put your finger on whatever's causing this with a bit of testing and without having to try any parts in it.
1986 745 D24T/ZF
1983 764 D24T/M46
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -8. The time now is 05:34 AM.

Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.