D24T.com  

Go Back   D24T.com > Technical Discussion Area > Help! My car died!

Reply
 
Thread Tools Display Modes
  #1  
Old 03-06-2016, 04:52 AM
rado561 rado561 is offline
Junior Member
 
Join Date: Aug 2014
Posts: 18
Default Bad sound and a lot of smoke

Hi everyone. My volvo got really annoying problem it sounds bad and smokes a lot. My pump is fully recycled in bosch service recently.After installing it that happened. Also there is a strange noise after releasing the gas pedal.Before that it was running well and clear also noisy and smokey but not that much. Any ideas? Here i have a video: https://drive.google.com/file/d/0B8-...ew?usp=sharing
Reply With Quote
  #2  
Old 03-31-2016, 11:13 PM
Slobodan Slobodan is offline
Senior Member
 
Join Date: Jun 2009
Location: Portland, OR
Posts: 208
Send a message via AIM to Slobodan
Default

installation must have been done wrong. sounds like the pump timing slipped somehow and its probably too far advanced now or retarded. I'd double check the pump timing. don't run it this way.
__________________
Redblocks are fun and easy but Greenblocks take skill.
'79 245 with D24TIC + M47
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:20 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.