D24T.com  

Go Back   D24T.com > Technical Discussion Area > Help! My car died!

Reply
 
Thread Tools Display Modes
  #1  
Old 03-17-2018, 10:07 PM
Impolvo Impolvo is offline
Supporting Member
 
Join Date: Apr 2017
Location: Chapel hill
Vehicle: 262c
Posts: 16
Default D24t wonít rev over 1000l sometimes

Resurrected after may years the 262c with d24t m46 did great
Pulled fine for what it is was getting 8-11 lbs boost
Changed all fluids belts
Fuel filter twice once after 59 miles
Was very old fuel
Itís a little hard to start (under powered battery
Like 550 cca 70ah

But today it finds emwant to jump to life like normal
Needed a jump start and many turns
Took it around the neighborhood but occasionally would not rev over 1k
Even parked in neutral but randomly would decide to work as normal

Any idea?
I know I plan on an in line electric pump to help the injection pump
But no matter how much throttle it wouldnít muster over a 1000 rpm
Then random moly itíd go away and be boost happy

Itís I thinkable engine from an 85-86 760

Any things that might be restricting it

I swapped coil control module so itís firing the coils now
Though I havenít checked if they are good

No fuel leaks
Just oil from a Ames oil relocation kit
Reply With Quote
  #2  
Old 03-18-2018, 08:51 AM
ngoma ngoma is offline
Senior Member
 
Join Date: Nov 2009
Posts: 618
Default

Have you checked for air bubbles in the "clear" fuel supply line feeding the IP?
Possible double inner rubber gasket on the fuel filter?

Quote:
Originally Posted by Impolvo View Post
I know I plan on an in line electric pump to help the injection pump
Why?
__________________
1985 744 gle d24t
1985 745 gle d24t
Reply With Quote
  #3  
Old 03-18-2018, 06:06 PM
RedArrow RedArrow is offline
Senior Member
 
Join Date: Jan 2013
Location: NY
Vehicle: 740
Posts: 512
Default Re:AIR

I recently had leaky injector nipples (4of6 injectors) AND multiple of injector return lines were worn at the end, those thin rubber hoses didnt seal right and they were constantly letting air into the fuel (and in injector pump)
No matter what I did with the pedal, the car would not want to rev above 2500rpm. But i was able to drive it for weeks like that. Since I jb welded the loose injector nipples and changed the return lines to the proper German ones, there is no air and it revs as it should. Also the filter housing bleeder valve (bolt) can be faulty (I had that because the thread got stripped).

I was about to open a new thread to ask why my car wont rev but the problem stopped after connections at injectors got fixed.

If you had recently added a new fuel hose or even just a hose clamp on that fuel line between the filter and the pump then re-checking them is a good idea. Mine lets air in bc of a small hose clamp that I added at the upper area where the hose reaches the IP banjo. Why? Because I could not find the proper inner diameter of a clear, diesel-tolerant hose... so I used a regular 1/4 US version, with a clamp to secure it.

The only thing I cant understand now is why my turbo spools so high at 65-70 where long ago I could do higher speeds 75-85mph at lower spools of the same turbo and same setups except the bigger gtd injectors.

Shall I advance the timing a bit? Add fuel by turning the pump up? Idk...ideas are welcome



Those 262c Bertones sat for about 10 or 15 years before you took them. The owner is a true dieseler and he put them together very well. They must be stable d24t motors in there! I hope he is doing fine too!
Could you use a jar under the hood and see if it runs well (or better. )
Post pictures and videos...you have interesting diesel volvo cars.

Last edited by RedArrow; 03-18-2018 at 06:12 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.