D24T.com

D24T.com (http://d24t.com/index.php)
-   Performance and aftermarket (http://d24t.com/forumdisplay.php?f=7)
-   -   KKK K24 From MErcedes DOES fit D24T (http://d24t.com/showthread.php?t=1626)

Slobodan 03-15-2016 09:51 PM

KKK K24 From MErcedes DOES fit D24T
 
Yes, It fits no problem. Just had to make an oil line for the feed.
KKK power.

ngoma 03-15-2016 10:13 PM

Good to know, thanks. Tell us how it performs.

Slobodan 03-16-2016 07:33 AM

so far boost comes on a little later, by 2000 rpms making 2 - 3 psi and 2500 making 10psi. Feels like it develops more torque through out the revs. Engine even sounds more radical from exhaust. 2.5" straight piped out the back.

I plan on bumbing up the boost to 15psi later this week.

raw 10-21-2016 12:02 PM

Do you guys in America get a different stock turbo than the uk tic 940s had? I'm seeing 10psi at 2000rpm and 16psi which is my NBC setting by 2600rpm with the standard turbo on mine. Hoping to go vnt in future as I'd like less lag.

Rich

Slobodan 12-01-2016 11:14 PM

Its been almost 9 months, been running it at 20+psi
I slapped on another KKK K24 turbine with K26 compressor.
MUCH Better!, boost hits much better. I dialed fuel back for time being, still very fun to drive, and not very smokey. just a little. thats what makes these engine last. Not rolling coal. just on the side of smokey. nothing crazy,
Car has a G80 lock in it now to help cope with the added power. still rocking the ZF 4hp 22 tranns. Added the extended range tank. going to be driving to sothern cali later this month. Engine is still pretty worn out. still starts in 30f weather. going to drive it till the end. then I'll be playing with a Mercedes OM616.

ngoma 12-02-2016 11:28 AM

When does the boost hit with the new version?

Slobodan 12-12-2016 05:59 AM

1800rpms I see 2psi and 10 psi by 2400 and 20 psi by 2800.
However since the cold weather hit, It couldn't be coaxed into starting up. NOT even ether, which is a big no no. but I was desperate to make it live again. "Just one day it won't start anymore."
seemed to be running fine, but getting harder and harder to start in the last 4 months.

ngoma 12-12-2016 12:08 PM

Quote:

Originally Posted by Slobodan (Post 11524)
However since the cold weather hit, It couldn't be coaxed into starting up.

First thought is glow plug health. They get hard to start with even one bad GP. Two or more bad GPs can make it near impossible. Second thought is possible air intrusion from a bad IP mainshaft seal. Have you looked into these?

Slobodan 12-13-2016 10:28 PM

I have checked glow plugs about 2 months ago, and all were working perfectly. they are only 2 years old. Bosch.
Its getting plenty of fuel. Even the ether couldn't get it going. Compression is just not there. Doesn't have enough compression to get ether to light it off.
Its ok. I am not heart broken. I do think I will be installing this OM616 I acquired. I'll probably do some cool compound turbo setup with it.

ngoma 12-14-2016 12:00 AM

Quote:

Originally Posted by Slobodan (Post 11529)
Compression is just not there. Doesn't have enough compression to get ether to light it off.

WOW, that is really low compression! :eek: How was the engine running, when it was running? What kind of air cleaner were you using? What kind of motor oil?

I bought one D24T car that immediately needed engine replacement. We figured it was because the previous owner lived at the bottom of a long steep hill. Evidently she would boot it going up that hill every morning, engine cold. Prematurely wore out the engine, compression primarily, probably not good for the turbo either.

What trans are you going to use behind the OM616?


All times are GMT -8. The time now is 05:34 AM.

Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.